Page 1 of 1

Disto A3 problem

PostPosted: Dec 13, 2009 8:46 am
by Lux
Not a while ago my friend gave me his old leica disto a3 (modded with bluetooth).

But it looks like it doesnt work as its supposed to.
when measuring over 14m, it prints only error "255".
anyone knows whats the problem?

Re: Disto A3 problem

PostPosted: Dec 13, 2009 9:43 am
by John Lovaas

The '255' error is a standard Leica code- it means the rangefinder isn't getting enough of the reflected light to get a reading.

When I get the message on my Disto X, it is because A) the instrument doesn't like the target or B) I'm not holding the instrument still.

What are you using for a target? Is there a lot of ambient light when you get the error?

Re: Disto A3 problem

PostPosted: Dec 13, 2009 9:56 am
by Lux
i'm using it in cave surveying, so there is not much of ambiental light.

i even tried it in pitch-black area, but same thing.
also, leica troubleshooting page says that for error 255 i should use targeting plate, but i have no idea what that is. :down:

Re: Disto A3 problem

PostPosted: Dec 13, 2009 10:54 am
by Scott McCrea
The obvious, simple question is are the batteries good?

Re: Disto A3 problem

PostPosted: Dec 13, 2009 3:11 pm
by Lux
Yes, i replaced them, even tried with rechargable ones... but nothing.

Re: Disto A3 problem

PostPosted: Dec 13, 2009 6:14 pm
by NZcaver
John is quite correct about the 255 error. It's the common code for most (all?) Disto units when the unit is out of range or otherwise can't get a good reflection off a target. Have you tried targeting onto a light-colored flat wall over 14m away? It *should* be able to go to 80m without a target plate. If the batteries are good and the lens is clean and it still does it, unfortunately you might have a bad unit.

For more information, click here and download the manual for the A3 (assuming you don't have it already). It's in PDF format, and it's free to download.

Re: Disto A3 problem

PostPosted: Jan 5, 2010 10:55 pm
by LWB
Has the Disto ever been taken apart? Since you say it has been modified with bluetooth, I would be concerned that enough screws were removed to disturb the factory alignment - which could certainly give the errors you are getting

The Disto X instructions are careful to warn against removed more than one screw at a time so the alignment is not affected.

I don't know that there is any way to fix it, if this is your problem.